How to: Installing VMware ESXi 4 on a 6 year old cheap motherboard

I’ve been trying to get VMware ESXi 4 on my old MSI MS-7388 motherboard for a long time. No matter what I tried, neither the SATA controller on the motherboard or the add on SATA controller would be recognized.

Install VMware ESXi 4.0 on an unsupported motherboard (SATA controller must support AHCI):

  1. make sure the SATA controller(s) is set to AHCI in the computer’s BIOS
  2. download VMware ESXi 4 iso
  3. burn the iso to either a cdrom or a USB thumb drive (512mb minimum) using unetbootin
  4. boot the computer into VMware ESXi
  5. Before you’re prompted to hit Enter to begin, hit ALT-F1 which will get you to a console screen without a prompt
  6. Type “unsupported” followed by Enter
  7. When prompted for a password, just hit Enter
  8. Type “vmkload_mod ahci” followed by Enter.  This will load in the driver for just about any AHCI compliant SATA controller
  9. Hit ALT-F2 to finish the installation

At this point VMware ESXi 4.0 will be installed but it won’t start when you reboot.  This is because VMware won’t load the AHCI driver by default.  So… we will have to tell it to load it automatically.  You will need a Linux Live CD such as Ubuntu.

  1. Boot into Linux
  2. From the desktop you will need to mount the VMware partitions.  In Ubuntu 8.04 and higher, you just need to click on the folders in the drop down menu
  3. Locate oem.tgz on the second VMware partition and overwrite it with this oem.tgz.  It includes a file telling VMware to load the AHCI driver
  4. reboot and boot into VMware ESXi

You should have a fully working VMware ESXi server installed and ready for you to setup virtual machines! 🙂

Share Button

8 Replies to “How to: Installing VMware ESXi 4 on a 6 year old cheap motherboard”

  1. My installation was hanging at “loading module hid”, which I’m assuming by the behavior of the machine during the loading of it, stands for “hardware identification”. Disabling all USB functionality in the BIOS allowed it to continue to the point that I could use the steps listed above in this article. However, I noticed that the “AHCI” module (which the steps above help you load) was ALREADY being loaded by ESXi4 (Update 1) during launch – you can just barely see it because it flashes by so fast, but you CAN see it load. Thus, following these steps for ESXi v4 Update 1 is redundant – if the normal ESXi install process doesn’t see your drives, then the steps above probably won’t either. To prove this, I successfully loaded the module according to these steps obove and ESXi (v4 u1) still completely failed to recognize my AHCI SATA controller (new ASUS motherboard).

    I’m sure these instructions above are fantastic information for earlier versions of ESXi, but appear to be pointless/redundant for ESXi v4 u1.

  2. Which motherboard are you using? Is the SATA running off of the motherboard or a separate card? I ask because I suspect that your motherboard may be incompatible with ESXi. Btw, what is your BIOS version and have you tried the different settings for the SATA controller (AHCI, compatible, etc) in your BIOS?

  3. I’ve just tried installing on 2yo asus mobo with SB600 sata controller. ESXi 4u1 will not pick up the SB600 controller. However with the trick mentioned above it worked OK. The only thing I had to do differently was creating my own oem.tgz instead of using the published here. PCI ids has to much exactly Your mobo.

  4. Thank you Jason for this!

    It works with 4.0 U1 for sure (Bob’s comments above are simply not true)!
    Also, guys, keep in mind that you will need to update the oem.tgz according to you own hw.


    BTW – It also works for 4.1 but I am getting another error that has nothing to do with the SATA drivers – “unable to find image to install image not being mounted correctly”.

    I will settle for the 4.0 U1 for now…

    Many thanks,


  5. Ok here is what i got, ive been trying to install vmware vsphere esxi, im a total newb to virualization, i did get vmware server up and running but there is to much going on and it looks very unfamiliar to me, im used to the vsphere interface in any event here is my current rig:

    Mobo: Biostar TA790GXB3 AM3
    CPU: AMD ATHLON II quad core
    Ram: 8gb

    Previous attemps:

    Disabled nic, fails to load
    Disabled nic, and changed raid to ACHI fail to load again

    I cant really read what it fails on because it looks like it stretches over to the other side of the moniter of which i cant even get to.

    Bios has been updated to the latest version virtualization enabled. Someone please help. Thanks for reading

  6. Hi,
    I would like to deploy the Vmware vSphere. My server machine is AMD Phenom 9950 Quad-core processor with 8 gb ram & 500 gb hdd.. It fails to installation.. I tried 3.5/4.0/4.1 but still no luck..
    I setup my bios to ahci as well..

    I got the following error

    The installation operation has encountered fatal error: Unable to find the supported device to write the VMware ESXi 4.1.0 image to.

    Pl guide..


    1. @Manoj, If you have followed these instructions sometimes you need to put in the command install and then put press alt+F1 again

Leave a Reply

Your email address will not be published. Required fields are marked *